Updated 2012-09-19 16:28:30 by LkpPo

GPS: April 20, 2004 - We now have 8.4.6 of Tcl and Tk in NetBSD's -current pkgsrc thanks to the pkgsrc people. It works very well so far in the 2.0 beta.

TclKit builds in NetBSD, but it fails with a symbol loading failure via package require Tk. I managed to fix the loading problem via this tiny patch to Tk 8.4.6's Makefile.in (note: I indented 1 space on each line for the Wiki):
 --- Makefile.in.orig    2004-04-20 16:54:47.000000000 -0600
 +++ Makefile.in 2004-04-20 17:10:47.000000000 -0600
 @@ -234,7 +234,10 @@
  # The values of the symbolis normally set by the configure script.

  STLIB_LD               = @STLIB_LD@
 -SHLIB_LD               = @SHLIB_LD@
 +SHLIB_LD               = @SHLIB_LD@
 +SHLIB_LD               += @XLIBSW@
 +SHLIB_LD               += @LD_SEARCH_FLAGS@

I'll see about getting this into Tk (if a similar isn't waiting (I recall Stu submitted a bug ...)).

GPS: Feb 18, 2004 - Steve Offutt and I are working to make Tcl/Tk work well with NetBSD. So far several bugs have been fixed in the HEAD of Tcl and Tk. One bug in particular was an improper [Tcl_DecrRefCount] that should have failed with all platforms during make test.

Extensions to Tcl/Tk seem to have the same problems as with OpenBSD. The extension developers don't follow the guidelines, so the library flags are wrong when linking. I built BLT 2.4z last night and it doesn't seem to use TCL_LIB_VERSIONS_OK='nodots' properly, so -ltcl8.4 is used rather than -ltcl84 which it should be.

Sadly, pkgsrc seems to have 8.3.4 and points to scriptics (as of Feb 12, 2004). I hope to eventually contribute some patches to pkgsrc to upgrade. On the upside pkgsrc has many useful Tcl/Tk developer tools and some applications.